Amazon Echo issue with Gen 2


#1

For the most part, it works with Alexa but I keep getting Alexa to ask which zone and how many minutes to run, even after saying something like “Zone 1 for 2 minutes” over and over, it still does not run. Right now, it is 50/50 that it works. I realize that this is still early, but I just want you to be aware that it is not working great.

I can say “Alexa Open Rachio”, then she asks “what would you like to do”. At this point it works better but still not 100%.

Just want to say that I really love your product. I am a long time software developer myself so I know the pain. Just want to say thanks for a well-designed product, Apple like, dare I say :smile:


#2

Hi @hln98!

Thanks for giving our Alexa skill a try!

Alexa’s speech recognition isn’t always the best. When I was building the skill, I also noticed that it’s a lot better once you’re inside the skill (“Alexa open Rachio)”. We have a support article, http://support.rachio.com/article/483-how-do-i-use-alexa, that outlines what the skill is looking for. After it re-prompts asking for the zone and how long to run for, have you tried saying “run zone 1 for 2 minutes” instead of “zone 1 for 2 minutes”? It’s fairly particular about using all of the words for the input commands. I think there is more that we can so on our side to make the experience a little smoother and that’s on my todo list when I get some free time. I’d welcome any other feedback you have!

-Tristan