Advanced adjustments for Rainbird continuous drip lines

It would seem my system has changed recently and so I need to get in and tweak some advanced settings and understand their impact a little more.

Firstly I have 6 zones all under one Flex. They are all low pressure Rainbird XFS drip lines with perennials. This post here is fantastic at explaining their water pattern and helped a lot: Drip math? - #16 by MarkSanDiego But I still have some specific questions.

@MarkSanDiego seemed to imply about all the changes that are required for more frequent watering with this type of system vs what Rachio is doing. I believe I have the opposite problem. My system is watering daily because it doesn’t think it ever gets the moisture level high enough. Here is one of the zones:

(this is all in cm not in by the way)
It was showing historically 0.06 per day of irrigation, and then nozzle cm/hr was 1.29. I bumped it to 2cm this morning and you can see in the graph it’s gone to .09 per day of irrigation. You’ll notice one of the oddities is it thinks it’s going to water over 2 cm of water “tomorrow” but that never happens. I’m pretty sure every day it shows the next day with a large amount, and then historically it’s always 0.06.

This is one of the zones, they are all pretty similar, with the only difference being the amount of light they get. It’s all default, except for the nozzle cm/hr which I changed today.

When I first made the Schedule, it suggested running each zone for 3 mins. That made no sense. I bumped it to 40 minutes as that’s about what I would think would be a good starting point based on previous experience. Overall, this drip setup should be longer waterings less frequently, but that’s not what’s happening.

I’m looking for advice on what settings to change such that it calculates more water after an irrigation.


Working with drip emitters is a little bit of math work and a little bit of guesswork.

When you bumped it to 40 minutes did you change the duration? If so, that messes with all your setting because the duration now overrides. I would get rid of that and start the zone over. Also, upping the nozzle cm/hr is going to give it less water instead of more for these drips because those emitters are probably not putting out that much water.

I realize this is a “line” and not “emitters” but I would think that since the water just comes out at certain spots on the line, it would still be similar to my emitters.

How I did mine was to run a drip zone by itself and measure the amount of water used at the meter, and then divided that by the number of drips to come up with a reasonable number. Mine are mostly 1/2GPH drips, which worked out to be about .2 inches/per hour, and each zone runs for 74 minutes. Because I am in a hot climate, they still run almost every day (sometimes every other day), but the plants are thriving. If I’m converting correctly, that would mean that most of my emitters are 1,892ml/hour and my nozzle is .5cm/hour. When I look at my details, the amount of water that I put down per day is pretty close to my evapotranspiration for the day – most times a little more, sometimes a little less. Since I have annuals mixed in with my perennials I also set my allowed depletion to 25% so that the annuals are always getting some water and the perennials still stay happy.

I would definitely not mess with the duration. In my opinion it’s best to play a bit with the advanced settings and you will get it dialed in.

Everything Linn said is correct, so listen to them.

I will tell you that your Advanced variables tell me that Rachio wants to put down, by default, 2.12 cm each time it water, yet it appears that changes you have made makes it think it will apply only 0.06 cm each time. Wait a minute: I see, scheduled for tomorrow, the 2.13 cm to be applied. Which should be correct. Previous days, though, were 0.06 and 0.09 cm. So as you say, something changed. Better to start over, as Linn says. With your daily ET above, for the past week, Rachio would water about every 4 days, which sounds fine. If you are really putting down only 0.06 to 0.09 cm per day, your lawn will be dead very shortly.

@adam said these lines are for perennials, so it’s even more critical! It may be my fescue grass, but I find my fescue can tolerate a less water for a bit, but my perennials and annuals will suffer quickly.

Thank you both for your input… Everything is very alive and well, I’m concerned that we are over watering though, so yes I was trying to reduce the amount being watered, not increase.

@Linn I’m not sure what you mean: “When you bumped it to 40 minutes did you change the duration?” When I first set up the schedule, at the end it tells you the duration, and it was going to do 3 mins per zone which made zero sense, so that’s when I increased it to 40. I’m not sure how else you can change the duration?

I didn’t realize messing with the time would throw things out of whack. But I will delete that zone and try again and see what it does.

This seems a bit odd: I have a vegetable garden zone I water daily and set it to complete by 9AM. My previous flex daily was set to end by 10AM. Now I am setting up the flex daily all over it says I can’t have two schedules both with specific complete before times. I’m sure I did before and now that’s gone!

Ok, now it’s even worse. I get to the end and it says 0 minutes per zone:

Something is not right.

@adam when @Linn mentioned the 40 mins thing that meant when you change a duration, the zone’s advanced settings won’t change. So you may look at your advanced settings and wonder why the calculations don’t add up. Best at that point to delete the flex schedule and start over.

Regarding your other inquiries:

I don’t think Rachio allows setting two of the same flex schedule start type. However, I’m pretty sure mine let me do that too at one point during initial testing of schedules (like one made via computer and one via phone app?).

I’m not sure how to help with your 0 minute issue. Zone settings drive those factors. Only thing I can think of is maybe you chose to water “Specific days” but didn’t actually select any days, so its doing 0 mins? I’m not sure if it even allows you not to select any days but worth checking on, might want to delete the schedule and start over again. Lol, sorry I’m not of more help.

Somebody else recently, who was also not in the US, just had a problem with the 0 min happening. Can’t do it now, but I will search around for it tomorrow, or you might be able to do a search for it.

Thanks @Linn I did a search and found this:

Says support told him the issue was he’s Canadian… ??? and it can’t be resolved.

This is my second time with this controller - I had one years ago at a different house with no problems so this is really surprising. I’m on with support now and will see what they say.

One other interesting thing - the web app gives me 0 mins, but the iPhone app gives me 3 minutes. Seems identical to @ReggieDied and his issues.

Another piece of information that is maybe helpful, but really just confusing. The last two days, irrigation has put down 1.25cm of water vs. 0.06 despite the same 40 minutes. If you recall, I upped the nozzle cm/hr from 1.29 to 2cm and nothing happened the first day, but now showing 1.25 from the irrigation.

Support confirmed with me this morning that it’s an issue that Engineering is investigating. So not so much it’s not supported in Canada, but something isn’t working as intended. They recommend a flex daily schedule in the meantime.

I’m a little concerned this isn’t documented anywhere and there’s no warning. You could lose a lot of plants thinking this is working properly and they get 0 water. The team at Rachio really needs to make sure this is known for users with a status page or something.

Assuming you haven’t changed the watering time manually, changing the nozzle inches per hour will NOT change the amount of water Rachio thinks/calculates/displays is being put down. Increasing the inches per hour will simply reduce watering time in inverse proportion, same with decreasing it. Increasing the inches per hour WILL change the ACTUAL amount of water put down, however, by reducing it. Because you haven’t actually changed anything, but told Rachio you did, so it reduces the time to accommodate the higher flow, thinking the water will be the same, but it won’t.

Thanks @rraisley really appreciate your time to provide me feedback. It took me a few reads to really comprehend what you’re saying…It does generally make sense. However as Support has told me things aren’t working as expected with Flex Daily in Canada, I’m not sure what to expect or believe now.

I do have one specific question from you with this statement:
“Because you haven’t actually changed anything, but told Rachio you did, so it reduces the time to accommodate the higher flow, thinking the water will be the same, but it won’t”

By time, I assume you mean frequency and not duration. By my reading of the documentation, Flex Daily will not change the duration of the watering, just the frequency.

Last thing, I did delete the schedule and re-create it. It came up with 3 minutes again so I bumped it to 40. Interestingly, that or something else has changed yesterday’s history. The same Zone I posted earlier now says it put down 0.09 yesterday instead of 1.25.

I think I just need to wait until they fix the problem with Canada.

Once set (where Rachio calculates everything for your zone), the duration will not change. It is calculated by the amount of water it thinks is required:

Water_per_Time = Soil_Available_Water x Root_Depth x Allowed_Depletion = 0.17 x 25 x 0.5 = 2.125 cm

The time to water that amount is calculated by:

Minutes = Water_Per_Time / Nozzle_Flow_cm_per_Hour x 60 min/hr / (0.4 x 0.6 x Efficiency) =
= 2.125 / 2 x 60 / (0.4 + 0.6 x 0.90) = 68 minutes.

Using the above factors, that’s what I think Rachio would/should calculate for watering time in minutes.

As long as you don’t manually change the minutes, Rachio /should/ recalculate everything according to the above. (I know you’re having a problem there, and can’t really comment on that. But this is the norm.)

Now, as you say, when temperature changes, Flex Daily will water more or less often, but in this case should always water 1.13 cm. BUT - if you change the nozzle cm/hour, Rachio should recalculate the time. Realize you’re not telling Rachio you need more or less water; you’re telling Rachio that your sprinkler heads put out more or less water than currently set, so it should recalculate the times. If you change the Nozzle cm/hour from 2 to 1, Rachio should double the time to water in minutes. And if you change the flow from 2 to 4, Rachio would halve the time to water in minutes. And it will STAY that way, because Rachio still thinks it’s putting down 1.13 cm, as that’s what it’s calculated.

This is why changing the Minutes directly, even if you’re fudging values, is a bad idea: because changing nozzle flow or anything else, after minutes have been manually set, with NOT result in recalculated minutes, so your actual flow stays the same, you are ignoring Rachio’s intelligence, and have taken over how much water should be applied each time.

1 Like