3e WiFi connection problems

I have tried to connect my Rachio 3e multiple times to my WiFi network. Getting very frustrated. I had a Rachio Gen 1 and it was very easy to connect.
I have a 2.4GHz router (Apple Time Capsule) about 10 feet from the Rachio. I’ve tried setting it up with my iPhone SE and 2020 iPad Pro both running iOS14.1
I also way get to the point where the Rachio app says ‘We could not find your Rachio’.
I’ve reset the Rachio multiple times.
I’m able to see and connect to the Rachio in Airport Utility from my MacBook Pro running Big Sur.
About to give up and return the unit. Please help

I’m not familiar with that utility. Do you mean that you see a network named Rachio-xxxxxx (where xxxxxx is the last six characters of the device’s MAC address)? If so, please follow the instructions in this video:

Or, do you mean that Rachio has connected to your Wi-Fi and you can see its IP address? If so, please post the light code signaled by the controller:

Also, provide details of all network devices (modem, separate router, etc.) connected between the Time Capsule and the internet.

IMG_0191
The Airport Utility is a built in app on iOS, iPadOS and macOS

Thanks, but you didn’t describe what you observed and did.

My issue is a the first one you listed. I have ride the option in the first video but will try it again. I have an older laptop and will use that one.
I have an Arris cable modem (not used as a router) connected via Ethernet to an Airport Time Capsule that functions as my wifi (802.11g/n/ac) router (2.4 GHz only). I use WPA2 Personal security.

If you see anything different from what is shown in the video, report details. If you complete the operation but it still doesn’t work, report the light code shown on the controller.

I used my wife’s older iPhone 8 and was successful. The firmware on the Rachio is iro3-firmware-hk-5-632 Is this current? If not, how do I update it?
Thanks for your help!

I had problem with a rachio 3. I reset wifi a million times with no luck.

But then I did a factory reset, which clears the entire device. Boom, wifi connected first time after that.

Give it a try.

Read on another post that if you have a Rachio 3 that can’t find WiFi (second light in the row of four on the front is pulsing yellow) you can use AirPort Utility on a Mac to configure it. Just look for the WiFi the Rachio is putting out and join it on your Mac. The AirPort utility will do some configuration from there. I thought it was crazy but I’ve fixed two Rachio 3s with this. One still had WiFi but no HomeKit so I reset WiFi, it couldn’t join again, hit it with AirPort Utility on a Mac and now I have HomeKit again. I’d been waiting months and months for a firmware update from Rachio but a WiFi reset and AirPort Utility on a Mac got me 100% back.