Unable to connect Rachio 3 to Wifi

As the title says, I am unable to connect my controller to any network. I finished my Ubiquiti Unifi setup by adding a switch (APs and USG as well), and created a VLAN for IOT devices. I tried connecting the controller to this network, but it has been unable to obtain a valid IP (stuck on 169.254…). Other devices can connect and receive a valid IP via DHCP, including the phone I’m trying to set up the controller with, so that’s not it. I factory reset the controller, but that didn’t solve it. I pruned the USG database with the controller unplugged to remove old devices, and that didn’t work. I tried assigning a static ip to the controller, but it sticks with the ad hoc network. So I tried reconnecting to the original Wifi network, and discovered I can’t even do that.

Both 5GHz and 2.4GHz networks share the SSID for both the IOT and original networks, but only the 2.4GHz network makes it to the controller’s location. I ran the RouteThis app next to the controller, and received the wonderfully opaque code D6ZKAD9G. I’m out of ideas and Rachio’s troubleshooting didn’t help. Thoughts?

Yea, the wireless radio on this device seems to be substandard. I have had numerous issues with it going offline and/or not responding to commands. Your story is disappointing as I plan on going to a ubiquiti system soon.

I have a similar setup to you @someone, minus the VLAN. I’m going to test my yet to be installed Gen3’s with the setup procedure, then set up a VLAN and re-run the set up and see if I have differing results. I’m suspecting that the VLAN might be causing the issue since I believe the Rachio Gen3 uses the phone to push the wifi information to it at setup.

I’ll try to get to that tonight and report back.

I got it working late yesterday. I deleted all my wireless networks, created the IOT network without assigning a VLAN, connected the Rachio, then assigned the VLAN. I’m not sure all that was necessary, but there seems to be something magical involving the first WiFi network and no VLAN.

1 Like

I figured it was something with the VLAN. Glad you got it working!

I’m glad that you got it working, but (for other readers), please confirm that when you ran the app to attempt Rachio configuration with the VLAN in place, your phone was connected to the IoT SSID, it had received a private IP address in the VLAN subnet, and it was able to access the internet.

Once it received a valid ip, I was able to assign a VLAN to the network, and the Rachio made the jump seamlessly. I can control it from my phone remotely or from the non IoT network.