Stuck wires in gen2


#1

Just wired up my gen2, made sure everything works, then tried to disconnect so I could manage the nest of wires. None of the spring clips will release my wires. I see the other threads on this subject and decided to start a new one to show that this problem still has not been solved in any long term way, and the solution appears to still be replacement of the entire unit. Bad way to start out. Why cheap out on such basic part of the product?


#2

How have you tried releasing the wires? A small Philips screw driver is recommend for this task.


#3

I had to use a precision flathead screwdriver and a pair of pliers (and considerable force) to remove them. The spring clip lever (ultra cheap plastic, like worse than toy plastic) is totally caved in on at least one of them. I managed to get it rewired but I don’t think I’ll ever get a third shot. At this point I’m making a recommendation to the company: find a better way to connect the wires. There are a million better alternatives.


#4

@nick I agree these terminals can be improved, and should be in the future. In the meantime, please know that if a terminal broke we will absolutely send a replacement. All you have to do is email support with pictures (proof of purchase is helpful as well) and they will get one sent to you ASAP. I know that does not solve the root of the problem, but I hope that helps!