So many problems going from Gen 1 to Gen 2


#1

I had the opportunity today to install my Generation 2 controller. I must say I had much more success with Gen 1. I first physically disconnected my Generation 1 controller and mounted the Generation 2 controller. I did not remove my Gen 1 controller from my account, since I wanted to be able to copy my settings. After powering on my Gen 2 controller, my problems began:

  1. The app could not complete adding the controller to my account, and the controller did not even seem to connect to my wireless router (no ip address issued). I did get as far as it asking for my serial number. My Nexus 5x with Android 6.0.1 showed the wireless connection go through this continuous loop of having an exclamation mark on my WiFi connection, followed by WiFi completely disconnecting. Then it would reconnect to my wireless network before going through this loop again. The Rachio app eventually errored out and asked if I wanted to try the process again. I did this numerous times without success.

I finally ended up unplugging the Gen 2 Rachio and powered it back on. This time the controller did finally activate, but it still went through that strange loop of causing my Nexus 5x WiFi connection to freak out.

  1. I copied my Gen 1 controller’s setting to my Gen 2. I use Flex Schedules, and there is a discrepancy between the two controllers on the next watering day. For two of the zones that my Gen 1 just watered 2 days ago, the Gen 1 shows that those zones will be watered after January 28th. My Gen 2 wants to water them tonight (15th). Two other zones that were not watered and show that they will be watered after Jan 28 on my Gen 1 show that they will be watered tonight (15th) on my Gen 2. Strangely if I put my Gen 2 in Standby Mode (since I don’t want these zones watered), my Gen 2 shows the same dates as Gen 1 (Jan 28th) for all zones.

  2. The moisture levels for all my zones on my Gen 1 do not match-up to my Gen 2.

  3. The next watering date for two of my zones as shown in the web interface do not match up with the mobile app. The web interface shows these zones will be watered tonight (15th), yet the mobile app shows after the 28th. The “Schedule Updates” on my mobile app; however, shows it is planning on watering these two zones tonight.

  4. On the mobile app, when I choose the controller I want to use at the top, sometimes the selection doesn’t work properly and both devices are shown selected, and you can’t do anything. If you go back and try it again, sometimes it will finally let you select the other controller, but other times it doesn’t. I eventually have to terminate the app to get it working properly again.

  5. When reviewing the “Watering Schedule”, my Gen 1 shows all my zones as “Any day at [time]”. My Gen 2 shows the same watering schedule expect it says “Every day at [time] as needed”. Why are these different?

  6. The Water Use in the web interface always shows one gallon more than the mobile app

  7. On Firefox (44.0.2) on my Windows 10 machine, which I used extensively with my Gen 1 controller with no problems, the web interface will get stuck at the “Rachio - Synchronizing user data” indefinitely. If I clear my browser cache, it will finally work, but as soon as I either launch the page again or refresh the page, it gets stuck at “Rachio - Synchronizing user data”. I’ve tried Chrome and Edge, and neither of them exhibit this behavior.

The upgrade to Gen 2 was not a positive experience for me, especially compared to how well Gen 1 worked. Its making me question the reliability of the product and wondering if I should have just stuck with the Gen 1 in the first place.


#2

@mandms7, we’re sorry to hear you encountered some issues with your Generation 2 controller. I’ll do my best to address your issues, below:

Do you recall what the lights were doing on the controller? Was Light 2 blinking or solid prior to unplugging the Gen 2? For anyone else experiencing issues connecting your controller to WiFi, it’s important to reference the light guide:

Additionally, we’ve been seeing some interference with WiFi assist functionality on some phones. In short, the phone will switch WiFi networks when it sees a stronger network available. Could you do us a favor and check to see if this feature is currently enabled on your phone? To check, please go to Settings -> Google -> Networking -> look for WiFi Assistant (or a similar name).

We apologize for any confusion with the copy feature; it currently will only copy the zone & schedule settings; all past watering events, observed weather, and irrigation events are not copied. We will work on a way to better message this.

If you’d like to delay your waterings, I’d recommend manually filling your zones using the Adjust feature within each zone. To access this, go to the My Yard card, select the zone you wish to edit, select Moisture Levels, select Adjust, then select Fill. This will override your moisture balance from their current % to 100%.

Correct, see #2, above. The copy feature does not copy past watering events, observed weather, or irrigation events.

I might be too late to see what you experienced. I’m showing matching dates for your Gen 2 on both mobile and web.

Thanks for bringing this issue to our attention. We were able to recreate and will be releasing a fix this week to correct it. A temporary work around is to not click on the circles but select the device name.

Hmm, looks like your seeing this on the web app? Looks like a naming variance. We’ll figure out what’s causing this discrepancy. Great catch!

Gen 1 web app

Gen 1 mobile app

Gen 2 web app

Gen 2 mobile app

Do you happen to have screenshots of this variance? I’m currently seeing 14 gallons used on both the mobile and web app.

Gen 2 web app

Gen 2 mobile app

The issue you experienced is due to a recent release of Firefox and not related to your Gen 2 controller. A temporary work around is to press ctrl + shift + r. We hope to have a fix out soon to correct this.

Please know that the Generation 1 and Generation 2 controllers use the same software; only the hardware and it’s feature set is different. The issues you experienced are largely rooted in the logic of the copy feature from Gen 1 to Gen 2 and should not reflect on the reliability of the controller in the future.

I hope this helps. Please reach out with any other questions or concerns.

Best, Emil


#3

I will review your response later but wanted to provide an update. This morning I woke up to a notification on my app that my Gen 2 was offline. I confirmed the same in the web interface. I went into my garage and saw it was still powered on with all lights solid. It is still in this state.

It is also showing two schedule updates where it is now planning on running two schedules today for no reason. My Gen 1 is still showing that things will be watered after Jan 28th.


#4

Thanks for the update. I will have our support team review your account and get back to you on findings.

:cheers:


#5

Device heartbeats that determine if it is offline stopped being received this morning, so we assumed the device was offline.

During that time everything was still running properly (schedules, etc.) and the device was online, etc.

If you have any scheduling questions, or would like a review, please reach out to [support@rachio.com] and they’d would be glad to work with you on that.

Thanks for your patience. Some exciting features coming out this year, stay tuned!

:cheers:


#6

@franz ,

I’m not sure if you’re stating that I should open up a support ticket for the various issues or not. I don’t have any questions related to scheduling; the Gen 2 device is simply not working like it should. This morning I put the device in Standby, so the schedules would not run (wasn’t sure if things would still run when it was showing Offline). After one of the scheduled run times passed (7:00 am PST), all the schedules corrected themselves and matched up to my Gen 1 controller. I now took the device out of standby, and after a bit of time, four of my zones are showing that they are going to be watered today again. This is not what the Gen 1 is showing.

With regard to the Offline status, what does this mean? I did not have any Internet connectivity issues today, so why would the heartbeats stop? You said the device was still online during this time; why was it showing offline then? When I checked on the device a bit later this morning, it was no longer in Offline mode.

@emil,
When I was first trying to connect the device, it was at Light Two (1 solid light with 2nd light blinking). On my Nexus 5x, I do have “Use open Wi-Fi automatically” selected, which I believe is the same setting as “WiFi Assistant”.

My watering schedules for Gen 2 get corrected whenever I put the device in standby and allow the scheduled start time to pass. If I then take the device out of standby, the correct times (as shown on my Gen 1) are shown. However, soon afterwards they revert back to wanting to water today. I don’t understand this.

Lastly, the mobile app you used to look at the gallons used is from an iOS device. I’m using an Android device, which is showing the discrepancy.


#7

@mandms7, no need to open a support ticket. I’m happy to address your questions here.

I believe we still have a disconnect on how Flex schedules work with the copy feature from Gen 1 to Gen 2; this feature only copied the zone & schedule settings; past watering events, observed weather, and irrigation events are not copied – these are used by Flex schedules to determine the next time your schedule will run.

I just reviewed your watering schedules and it appears the user fills you did on the Gen 2 zones corrected the forecasted next waterings:

Gen 1 Flex schedule by zone:

Gen 2 Flex schedule by zone:

Additionally, the schedules on your Gen 2 no longer change when the controller is put on standby mode.

This issue was resolved this morning on our end and was only a notification error; your controller never actually went offline.

Thanks for confirming. We’ve been seeing this feature causing interference on some phones during the controller’s WiFi setup.

This should be resolved going forward as the moisture graphs for each zone on your Gen 2 closing match those on the Gen 1.

Thanks for clarifying. I will check for the discrepancy on an Android device.

Please let us know if you have any other questions or concerns we can help with.

Thanks, Emil


#8

Thank you. I can confirm the schedules of my Gen 2 and Gen 1 now match. I appreciate your assistance.

FYI. I reported the bug regarding the discrepancy of gallons used in the Android app vs. the web interface about 1.5 months ago.


#9

We will be releasing a new version of Android today to address the issues above. Thanks for pointing these out.

:cheers:


#10

I wanted to report back that most of the issues I reported above have been resolved. Thanks for the timely updates. The one outstanding item from my original list is item 6 regarding verbiage difference on watering schedules.


#11

@mandms7, awesome! Glad to hear the schedules are running properly again.

I believe you’re referring to this:

Are you seeing this in the Android app or just the Web app? I’ll have to buy different cookies to bribe the team responsible :wink:


#12

That’s some good looking hard scape homie


#13

I’m seeing the behavior in both the Android app and Web app. I went into my “Lawn” schedule, made no changes, and simply saved the schedule again. It changed the description from “Every day at [time] as needed” to “Any day at [time]”.


#14

I had a very similar install problem, interestingly also with the Nexus 5x. However, the problem wasn’t with the phone. It seems the serial number entry defaults to the wrong setting. On the phone there is a dropdown for the serial number prefix. Mine defaulted to CR, but the correct prefix was VR. Changing that dropdown did the trick and my controller connected perfectly.

Had to call support to get that information.


#15

I know it’s too late, but we will be auto-populating that. Thanks for the feedback, we definitely have heard that a lot.

Submitting iOS/Android clients next week to not have you pick the serial number prefix. Definitely an oversight on our part.

:cheers: