SmartThings broken?

Was something changed recently that broke the SmartThings integration?
Everything showed as offline (I used to see the controller and each zone). So I removed everything and started over.
Now in the Classic app the zones and controller appear, but the Controller thing is the only one that responds to commands.
In the new app nothing works at all.
Not a deal breaker as I only use it for maintenance troubleshooting, but for now I have to resort to the iOS app.


I’ve had a similar experience. I can’t figure out a single function that the SmartThings integration can perform. I wanted to turn on a zone with a SmartThings button, but none of the zones show up as devices that can be controlled…

The new app is totally DOA, says can’t connect to anything. Funny thing is when the issue first occurred I removed the Rachio connected service in the settings in the app. When I re-added it via Rachio connect it does not appear as a service.

In the Classic app it looks like it’s working and you think you can turn on zones individually but nothing happens at the controller. But if you turn on the controller itself from the app you do get a quick run.

I kinda hoped we’d hear something from the Rachio folks, I guess I’ll try and open up a support ticket.

The buzz on the SmartThings community isn’t much better.

Yeah, that’s where I picked up the idea to remove it and re-connect!

Some things just need to be left to the old app for now. Like a number of devices out there, Rachio works fine in the old ST app (Turning “on” runs a 10 minute quick run on the controller, just tested before responding), but not so well in the new app. Not sure where the breakdown is, or who’s issue it is to fix, but Rachio isn’t alone!

OK, let’s stick with the Classic app. All the zones appear in the old app but cannot be used to turn on a zone individually like they used to. I already said you can turn on the controller and get a quick run, but that’s less than the old functionality was.

Oddly enough, I was screwing around trying to get some new switches added for my pool lights last night, and Rachio was working fine in the new app… :man_shrugging:

So what’s the secret?
Out of curiosity is the service showing up for you?

My sprinkler zones show up, yes,

Clicking the power icon in the corner will start up a quick run in that zone, but clicking to the details page doesn’t show anything useful.

If I try to assign a button to quick run a zone (or build a new ‘automation’) the sprinkler zones are missing from the “outside” list.

Interesting! What about the Connected Services list? (Hit the hamburger upper left and then the gear wheel)?

That seems to be in order, yes.

My problem seems to be I cannot restore the service. I tried logging out and back in. with Rachio Connect in both the new app and the Classic app and it just won’t reappear!

Thanks for checking! :slight_smile:

Not sure…

I pressed the power button in ST and it triggered a 10 minute quick run. Stopped it, ran it again, and on the second stop attempt I got a network error in ST…

Are you able to automate it?
Could you make a SmartThings button or lightswitch run a zone as a test?

Yea, when I get home, I’ll try it.

Just created an automation when I turn on my front porch lights (zwave switch), to turn on Rachio “middle grass zone”. By the time I opened my front door the zone kicked on for a 10 minute quick run.

And this is with the ‘new’ app, not ‘classic’ right?

When I try to create automations, my Rachio zones disappear from the list…

Curious… I removed the service, and re-added it again.
This time the app asked me what room I wanted my “Sonos” in.

I added it to the garage (previously “outside”) and the zones show up as controllable devices now!

I don’t know if there’s some kind of hiccup with the Sonos integration, or if it was magical to assign the Rachio to a different room the second time, or what… But it works now, so there’s that!