Setup process recommendations


#1

I would like to preface my suggestions by stating the support staff is superb, and their effort and assistance kept me working to find a solution to my setup issues.

My first suggestion would be to have the App and online dashboard display the controller device firmware and OS version at the very least for troubleshooting purposes. Having a way to pull & submit device log information directly to Rachio support through the App would also be a nice feature.

Secondly I would suggest that the setup process not be an all or nothing process: the first part to sync the App to controller device should be independent of the second part which is the online connection and activation of the controller device.

My setup process was insanely difficult and gruelling simply because the Gen2 device I purchased was older and had an outdated firmware; the one with issues connecting to a dual band router, which I have. With both of my suggestions implemented it would have nearly eliminated all the hours of effort over the course of almost a week that was invested by both myself and the support staff getting my controller device connected and setup.

An alternative option to my second suggestion would be to include an ethernet port for the initial device discovery, App sync, and online activation. To prevent unwanted tampering this could be accomidated via a removable accessory or include functionality within the App to disable a fixed port.

Thanks again Rachio support for ALL of your help getting me setup!

*** For those interested I was finally able to complete the setup process and receive all firmware updates by connecting to the controller device via an old wifi only Zoom tablet and using the hotspot function on my phone to create a network for them to connect to. Once connected I let things sit for about 4 hours then shut it all down, performed a network reset on the controller before performing the setup process again.


#2

Hey @imatechguy!
Sorry to hear you ran into some issues getting your controller connect. Thank you for the input, I can definitely see how these could help when running into issues during the setup process of a device! I will make sure to get these in front of the product team.
Happy posting!
McKynzee :rachio:


#3

Wow, this is quite an ordeal you went through here, @imatechguy, and makes me appreciate my luck with the installation even more.

You will find that several of us here are pushing for ways to export settings for diagnostic and backup purposes. For situations like yours I would even go a step further and suggest a remote login and control. When in great pain, I sometimes reluctantly give a helpdesk remote access to my computer for the duration of an investigation, so I would certainly be open to let rachio tunnel into my Gen2 with the same permission procedure.
I assume this would be a dream for the tech support as well.


#4

@mckynzee - thank you, being able to get more detail sooner in the process would definitely be helpful for both the consumer and your tech support folks. Odds are this won’t be the last firmware based issue you ever have and even in other scenario’s that separation in the process could prove helpful.

@hgugger - it was a serious exercise in frustration. Through no less than 50 device resets, an email chain with the excellent tech support folks that contained almost 15 responses from me to at least 4 different support personal across the days as new shifts took over and 3 phone calls, one at least 45 minutes long. They stuck with me for every bit of it scratching their heads trying to figure it out as much as I was. We honestly tried every configuration and setting alteration possible. I was about ready to take the controller back for an exchange thinking it faulty when I thought of using my phone hot-spot to create the wifi network and using my old Xoom to run the App. When that worked flawlessly it made me want to solve the problem even more.

Remote access is a great idea, unfortunately in my case it would not have been possible. That is because my device firmware was an older version that didn’t work with dual band routers so it could not connect to the web so no remote access; and because it couldn’t connect to the web it couldn’t get the firmware update it need that would let it play nice with a dual band router. Once I left the controller connected to my hot-spot for a few hours it got the firmware update it needed and then connected to my normal home network without issue. Now my only worry is whether or not it’s working (it is) because I set it up the flex-schedule.and we’ve had so much rain lately my sprinklers rarely go off now and not having to manually adjust the timing still seems odd.
.


#5

Good point @imatechguy, remote access only works once you are connected :smirk:

Regarding FLEX, expect some initial experimentation (and occasionally a manual intervention) to get the best result - it is absolutely worth the investment in time. Once you have established a solid set of parameters, it works fabulously, at least for me. In your case I would recommend to directly reach out to the rachio team to guide you through the advanced settings, so you lose no time. A major choice will be the weather station, since FLEX uses it for at least the past and current climate values, but a more evolved service (Aeris) for the forecasting. I guard myself against watering after a very localized rain with a rain sensor. If the weather cells miss you, you can still manually run (which I only did once or twice). Also, smart cycle is useful in minimizing runoff - which I consider a great feature if you have sloped zones.

Hope you are past all the understandable frustration after this nightmare, and can join us now for the fun part! You will be surprised how amazingly resourceful this community is; if you make inexplicable observations or if things doesn’t quite work as expected, share the data and you will get people engaged.


#6

Hi, I may have the exact same problem. I’m waiting for support to chime in, but it seems that no matter which WiFI network I connect to, I have the same issue. I even tried a hotspot connection on an iPad, nothing. I’m very sad right now that I don’t have a working Rachio yet. :disappointed:


#7

@hgugger - I’ve got things fairly diaaled in right now. Yes smart cycle is great and definitely enabled since I like the idea of water and soak cycles even on the part of the yard without a slope. I’m a convert from Lono and need something that works the way it’s supposed to and has active development; so here I am. Lono was a great idea when I supported the kickstarter but those guys are in way over their heads, there was too much flakiness in schedule running and no actual “smart features”. If the community here is as supportive as Rachio’s own support then few if any issue’s should go unresolved. I’ve enjoyed just reading posts and responses so far, a good sign to be sure. I love the engagement of the staff and responsiveness to development ideas I saw in that sub-forum.

@johnmartinez - When you tried the iPad was it connected to your home network or does it have it’s own data plan? You will need the device being used as the hotspot to provide it’s own data connection. If the iPad is using your home wifi to get the internet connection then you’ve not changed anything related to how the controller is trying to connect to the internet. As long as you are using a cellular network for the internet connection and a separate device to run the App and setup it “should” work.


#8

@imatechguy - yeah, it was using the iPad’s data plan (I use it all the time for work, I travel a lot). So all things considered, it should have been a totally new network outside of my home network.

I sent a bunch of diagnostic data to support (I’m an old network/computer dude and run my own home network setup) and all things point to a bad controller.

thanks!


#9

Something else that’s telling is that the controller seemingly establishes a connection with my wifi AP, but I notice in my DHCP server logs that it keeps wanting a new lease. Also, my AP logs show a bunch of connection attempts when I was trying to point it at my AP network.

This definitely looks like connectivity issues, so it may not be the same thing you saw. I’ll keep this thread updated!

-john


#10

John - what I was seeing was the controller get assigned an IP address from my router, I could see in my router logs that the controller was trying establish a connection out it would get to the third light blinking but setup would not progress further than that. Ditto the old, network/computer guy and run own network part. Yep, a bad controller is exactly what I was thinking too, at least until it connected via my phone’s hotspot. You might also give them your router make and model to see if it’s on the list known to be problematic, assuming they haven’t already asked that question.

Some other things I thought of…

  • Perform both a network and factory reset on the device, unplug it, plug it back in and again do the network and factory reset to make sure you clear all the old settings out. I know it’s a little extreme but I like to be sure.
  • Make sure you have the phone or device running the App forget your home network because otherwise I saw the device running the App try to reconnect to my home network wifi as it went through the setup process.
  • Make sure location access is enabled on both the hotspot and device running the App.
  • Ensure the hotspot SSID is being broadcast

Good luck, I do hope you can get this sorted out because everything works and functions quite nicely once you get past initial setup woes, for those of us that have them.


#11

@johnmartinez - I just saw this on the community home page. Might be related, might not be but thought I’d point it out just in case.

http://community.rachio.com/t/gen2-wont-connect-to-cloud-during-setup?source_topic_id=6277

#12

@johnmartinez

If you tried to connect a Gen 2 today we are having issues with Amazon and service configuration with their IoT cloud (they changed SSL certs with a different start date then our controller likes)

Thanks for your patience, and please let me know if you have any other questions. The Amazon team is working on a solution and we will know more tomorrow.

:cheers:


#13

Yep - @imatechguy @franz Rachio Support think that is more than likely my issue and I’ve setup a limited schedule in the meantime. You guys (Rachio Support) ROCK! :vulcan:


#14

Ok, if it’s a new gen 2 and today is the first day you tried to activate it, it could very well be our issue.

The new SSL certs were rolled out by Amazon at 12:00PM MDT.

:cheers: