Programmed flex schedule,didn’t like. Programmed fixed schedule. Changed back to flex and it scheduled for ten days later. At 100 degree weather that won’t do. Unable to switch back to the fixed schedule

You can’t “switch” schedule types. You just make a new schedule of the type you want.

But no way would a Flex schedule wait 10 days to water in 100 degree weather (maybe in 70 degree weather, but not 100), so something’s definitely off there. You may want to share your settings to find out what’s up.