Rain delay bug


#1

One of my zones is a covered nursery. It shouldn’t be subjected to rain delays.

You provide the option, in fixed schedule mode, to ignore rain delays for specific zones, but it doesn’t work.

I’ve emailed you about this, and you’ve acknowledge that it’s a problem. So… any progress? When will you fix this bug?

It’s gotta be a simple one-line code fix, like:
if (isRainDelay && !zone.isIgnoreRainDelays()) {
skip(zone);
} else {
water(zone);
}


#2

Hi @dimitri-
I think the issue here may be there is confusion between the “Rain Delay” feature and the “Rain Skip” feature. Rain delay is the option under your device on your dashboard screen. It puts your system on “pause” for a certain amount of days, and is not impacted at all by weather. Rain skip is a weather intelligence feature, and skips your schedule if your weather station reports enough rain to meet whatever threshold you set.
My recommendation would be to put your covered nursery on a separate fixed schedule from the rest of your zones, and disable rain skip for this schedule. You can then enable rain skip on the schedule(s) for all of your other zones!
If I am misunderstanding your issue, let me know!!
McKynzee :rachio:


#3

You don’t have the full email conversation, between me and your customer service coworker, Jared.

The only reason I’m even trying to use the “Rain Delay” button is because Rachio doesn’t support skipping specific zones. So, Jared, your co-worker, said I should use the Rain Delay instead.

But, apparently, that workaround doesn’t work either.

Please, either enable Rachio to skip specific zones, or change the Rain Delay button to be smart enough to understand that some zones (e.g. ones configured to ignore rain delays) must always be watered. It should be irrelevant if the rain delay is triggered by your IRO’s rain “intelligence” or MY brain’s intelligence.

Please, help me. So far, this past year has been nothing but headaches. I would’ve been better off with a dumb water controller + rain sensor. Have I thrown away my money by purchasing a Rachio Iro?


#4

Where do I find the ‘Rain Skip’ feature?

I’d like to check that I have it enabled.

I’m using IE, latest version.

Thank you.

Best regards,

Bill


#5

Hi @dimitri-
I looked into your conversation with Jared, and now I have a better understanding of your situation. I see that you already have your covered nursery on it’s own schedule that does not have Rain Skip enabled, and the rest of your zones are on a schedule with Rain Skip enabled. For the issue you ran into that weekend- the reason your schedule was still planning on running was the precipitation did not meet your Rain Skip threshold, which was 1/16 of an inch (precipitation was recorded as 0.03 in.) Just so you know why that happened!
For your situation, I actually don’t think Rain Delay is the best solution. A better option would probably be to disable your schedule with all of your zones except your nursery on it. This can be done by selecting your schedule and changing the enabled slider to off. What is difficult about this is you have to remember to switch it back on when you are ready for it to begin running again. I understand this is not an ideal solution, but hopefully it can be a useful workaround! I will also make sure the product team receives your recommendation on how to improve this. I apologize for not having a better understanding in my first response!

@a0128958- You can find the “Rain Skip” feature by selecting your watering schedule, then scrolling down and selecting Weather Intelligence. There you will see all the weather features available and it will tell you if your Rain Skip is enabled or not! If you select Rain Skip, you can enable/disable it and also change your threshold for the skip. Let me know if you have any other questions about this!

McKynzee :rachio: