Rachio online in app but error could not connect to device


#1

Hi I just bought the 8 zone Rachio and hooked it up last night I have an Android phone with the app and it shows the Rachio online and the WiFi light is blinking green but I can’t send it any schedules I get the error message “Could not connect to device”. I get the same error when trying to toggle the rain sensor switch. I have also tried turning on the zones and nothing happens. I disconnected the rain sensor and it still doesn’t work. Below is my wiring if that helps.

Any help is appreciated.
Mike


#2

@hollowel

If you logout/login to your app this issue should be fixed.

:cheers:


#3

Wow thanks for the fast reply That fixed it!!!


#4

I have the same exact problem, and tried to logout/login, but it still had the same error. I uninstalled/reinstalled the Rachio App, and also re-started my phone. Still doesn’t work. Please help. Thank you.


#5

Support has resolved this issue with your device, if you logout/login to the mobile app should be good to go :wink:

:cheers:


#6

Wow, thank you VERY much! This is the fastest technical support response I have ever received.


#7

@franz: I hated to bump an old thread but this is the exact issue I am having with my device. It is showing online in my Android app and the webapp but I cannot access the Rachio to save my schedule. Can you or someone else look at my Rachio? Thanks!


#8

I just checked and everything seems to be ok on our end (device connectivity, etc.) but it does seem like any action with the device errors out.

I noticed the firmware is actually an older version that needs to get upgraded.

I also noticed that the signal strength from the router is really, really strong.

I know that we’ve had a few customers where the router is too close it doesn’t connect properly and update.

Can you try moving the Iro faceplate further away from the router and doing a power cycle to see if the firmware gets upgraded? If that doesn’t work, I will have the support team get a new unit out with newer firmware.

:cheers:


#9

Last night I put it back in the garage and this morning I power cycled the unit. I was able to save a flex schedule to the device. Can you please take another look and make sure everything looks good? Is there a way for me to do the firmware update on my end or does it push automatically?


#10

Just checked the device and everything looks great.

Please let us know if you have any other questions or feedback.

Have a great day!

:cheers:


#11

I am having the same problem. My unit is online, but when I try to create a schedule, I receive a"Could not connect to device" error.

I tried logging out of the app, and logging back in, but no joy :disappointed:

I re ran the wifi setup and now the problem is solved.