Rachio gets stuck on distant WiFi access point


#1

My home’s WiFi network consists of several Ubiquiti UniFi access points, all serving the same SSID. Mobile devices roam seamlessly from one AP to another.

I have two Rachio (Gen2) controllers. Ordinarily, they connect to the nearest AP and everything works fine. However, if that AP goes offline (even for a short time), the Rachio devices reconnect to a more distant AP, resulting in marginal communication. Even after the nearby AP comes back online, the Rachio devices remain stuck indefinitely on the distant AP.

This situation can arise after a power failure, when the devices come back online in an unpredictable order. If I see that a Rachio has connected to a distant AP, I can force it to reconnect, and it will correctly select the nearby AP. But this is a manual process that I would prefer to avoid.

I have worked around this problem by defining a second SSID that is served only by the nearby AP, and configuring the Rachio devices to use that SSID. This seems to have resolved the issue.

My suggestion is that the Rachio WiFi should periodically check for a stronger signal than the one it is currently using and should reconnect if so. This is analogous to the roaming that mobile devices do. Since Rachio controllers aren’t mobile, they only need to do this occasionally so as to adapt to any changes in the local WiFi infrastructure.

(Perhaps this should be a Product Suggestion rather than a Support topic.)


#2

Hey @eataft!

I would have recommended changing the SSID, so I am glad that is working for you. I am actually going to switch this to “Product Suggestions”, as I think it would fit better there! As homeowners continue to upgrade their wifi networks, I can see this becoming a more prominent issue.

McKynzee :rachio:


#3

I have ubiquiti as well, great stuff. My suggestion is to create a ssid for rachio and attach it to the one antenna closest, then reconnect rachio to that Sid. I hope you are not using zero handoff, it is horribly buggy and can lead to this behavior


#4

This is a more general issue I have since I’m running multiple APs and have quite a number of IoT devices. When I did firmware updates on the APs in a rolling fashion, all the IoT devices hopped onto the AP that wasn’t being updated, then jumped onto the other one when that AP underwent its update.

I’d prefer if each IoT had client roaming logic built in (but they likely don’t since they are expected to be stationary - and not taking into account wireless network designs with multiple APs) so that each device could figure out which AP was more appropriate given their location.

Definitely don’t want to subdivide my wireless networks into an IoT_front and IoT_back ssid setup to get around the lack of client roaming logic on the part of the devices.

The advantage of running a single ssid is that all the devices will still have a connection available if you need to take any AP down for servicing or other reasons.


#5

Usually this is not a problem, ubiquiti’s Zero handoff is just bad buggy. Their newer ac antennas roam pretty well.

If your site is laid out well, you can try using minrss to kick clients and have them reconnect, hopefully choosing the closer antenna.


#6

I’m using the newer AP-AC-LR models and have my APs on the same ssid but different channels. Kicking devices off an AP and hoping they go to the other one sometimes works, but sometimes they are too stubborn. First world problems…


#7

Yea I used to have the lr’s, the problem is the client gettin back to them. They are great if you are bridging.

I would set the signal strength to medium and see if that helps. The clients are supposed to reconnect when the signal get weak/faint, but the problem with those lr’s is that your clients are at a rock concert.


#8

I use a Ubiquiti Unifi AP-AC Lite for WiFi service to my home instead of the built-in WiFi capability that’s part of the cable company’s supplied router.

What AP-AC Lite setting should I check for maximum broadcast signal strength?

I’m not as smart as you guys are on this stuff, and I have some thermostats and a water heater that are on the fringe of good WiFi reception. I’d like to check that I have my Unifi AP-AC Lite set for max broadcast signal strength (only have one for my residence).

Many thanks!

Best regards,

Bill


#9

Lots of good advice here. I have the UniFi AP-AC-LR model, and I have tuned down the 2.4 GHz power levels so that overlap between APs is about -67 dBm (different channels, not using zero handoff). iPhones and other mobile devices roam between APs just fine.

The problem with the Rachio device is that if it happens to connect to a distant AP, it will stay stuck on it no matter how weak the signal is; it will let go only if the signal disappears altogether. The distant AP measures -93 dBm at the Rachio, but that is good enough for the Rachio to remain connected! Judging from what wx16 said, this problem occurs with other IoT devices as well.


#10

Yeah, my LRs are already on medium and some IoT devices just like to glue themselves to the first AP they ever met. WiFi love at first sight…


#11

This is what minrss is for, To disconnect your client when they are stuck on a distant ap so they negotiate with a closer antenna, if one is not around, the antenna will allow the client to persist upon reconnect


#12

It could also indicate a power imbalance between the Rachio and the AP (i.e., the Rachio “hears” the AP at a higher power than it can transmit, so it doesn’t try to find a better AP). MinRSSI can help with that, but it’s really the wrong solution to the problem, and turning down the AP transmit power would be better.

In my case, I have several UAP-AC-LR devices scattered around my house, with one on the inside wall directly adjacent to the Rachio on the outside of that wall. The Rachio is actually the best of the IOT devices that I have at attaching to the right AP with minimal fuss, and often the only thing that I have to do is issue a “reconnect” from the Unifi controller to set things right after an upgrade or power cycle.

Having said that, some of the most recent beta firmware releases support 802.11k, and I’ve found that that really messes with IOT device connections. I’m currently running a development firmware build that strips all of the 802.11k code out and things are stable now, but I saw very similar behavior to the OP with recent beta versions, even with “fast BSS transition” disabled.

The thing that drove me to setting up a separate 2.4G IOT SSID was the pairing process that many devices use these days. They try to attach to the network that the phone is using, but most don’t support 5Ghz. Sometimes it works, sometimes it doesn’t. I just gave up and gave IOT devices their own network.