Rachio gen 3 won't connect to my wifi

I have a Mesh network with 2 extenders in the house.
I have tried several times by resetting wifi and factory reset of controller but still not able to get the controller online. I tried using iphone and android both, same problem. I am about to send this damn controller back if I don’t get it working by tomorrow. Already spent enough time on it.

Since you have two phones, it should be easy to determine whether there is an issue with incompatibility or configuration of your mesh network.

I’m assuming that you have a Rachio 3; provide details if not.

  1. Confirm that you can get the controller into the ‘awaiting Wi-Fi’’ state with quadrant 2 blinking.

  2. Confirm that when you search Wi-Fi networks on one of your phones, you see the controller broadcasting a Rachio-xxxxxx SSID (network name). You don’t have to actually attempt connection.

  3. Set up the iPhone as a mobile hotspot. Confirm that the Android phone can connect to it and access the internet. Disable mobile data on the Android. Attempt to use the Rachio app on the Android to connect the controller, using the SSID and password that you set up on the hotspot.

  4. If connection is successful, please post: ISP? Modem make/model? Mesh router make/model? If different, extender make/model? Signal strength at Rachio controller? Are 2.4 GHz and 5 GHz SSIDs different? If so, have you tried to connect Rachio to both? Other than SSID and password, what non-default settings do you have in your network gear?

  5. If connection to the hotspot also failed, not the error messages and final state of the controller lights. Repeat the process using the Android as the hotspot and the iPhone running the Rachio app. If successful, return to step 4. If also failed, post details about error messages and light codes.

Some mesh hardware that uses the same SSID for 2.4 and 5 ghz like eero have a Troubleshoot step to temporarily disable the 5ghz radio to help devices connect. That might help or at least eliminate a common problem.