Rachio Gen 2 randomly goes offline


#1

Hello all,

I just got a Gen 2 controller. I have a good wifi signal. (Goes from full bars to 2 bars occasionally.) It was online most of the day, but has gone offline twice. It would not reconnect by itself. I checked and the signal was strong. I had to restart my router in order for it to connect again. It this a known issue as I could not find anything that is exactly like my problem.

BTW: During my initial set up I received the “an unexpected problem has occurred” message. I had to restart my router to get fully set up. Is this a router or a Rachio issue? All my other devices do not have connection issues.

Thanks!


#2

Don’t use the same ssid on 5ghz and 2.4ghz. You must have descrete ssids per band.


#3

The SSID for each band is different. What do you mean by “discrete?” As the Rachio cannot support 5ghz, how is this an issue?


#4

If the 5ghz and 2.4ghz is on the same ssid the rachio chipset will sometimes attempt to latch onto the 5ghz band. Most of these cards can see the ssid on the 5ghz band but can not negotiate keys. A lot of chipset manufactures jumped to 5ghz before the spec was ratified. Back in the day you would see a 802.11 n plus, sometimes they would say n with boost. But since you have 2 Ssids, one for the 2.4 and one for the 5 band, you might need to email support@rachio.com.


#5

I apologize, but I am not entirely IT savvy when it comes to router terminology. I will call support tomorrow as I am not sure exactly how to change the SSID as I think they are different.


#6

Cool, good luck, post back your solution if you could.


#7

Tried to “forget” the 5g with my iPhone and reconnected to the Rachio by the changing email method. I just checked the app remotely and the unit is disconnected again. A bit frustrating.


#8

@MikeyUSC support@rachio.com will be able to assist with troubleshooting. Once the problem is resolved please post back with the resolution.

Thanks!

:cheers:


#9

What does this mean? (Don’t use the same ssid on 5ghz and 2.4ghz. You must have descrete ssids per band.)

Thank you.

Best regards,

Bill


#10

Some waps will let you assign the same ssid to your 5ghz and 2.4 ghz band. They should be different, a lot of 2.4 ghz chipsets will try to latch onto the 5ghz.


#11

Thank ypu

I have made the change in my router.

Best regards,

Bill


#12

Update…problem still persists. However, I found a pattern that when I leave the house, the Rachio goes offline. Maybe it is a coincidence, but it has happened 3 times already. It also seems to do it overnight for the last two days I have had the unit setup. I talked to support for Rachio and NetGear (my router) and still no success. I was able to reserve the IP address on my router and yet it still goes offline. Rachio support could not figure out the problem as everything on their side seems to be normal. If it goes offline again by tomorrow, I will call again. We may need to swap out the unit.

Also, a strange thing happened today where it went offline, then suddenly went back online while I was out. I tried to manually run my sprinklers and the app showed “watering” but nothing was happening with my sprinklers. I checked the unit, and it was stuck as usual 1st light solid and the second light blinking. I restarted the router again and the unit successfully connected. I am hoping it is a software glitch that can be solved remotely, but I am beginning to think it is a faulty unit. Not what I expected after reading the great reviews of Rachio. BTW: Support for Rachio has been excellent. They have been trying their hardest to solve the issue.


#13

@MikeyUSC I’m going to have our firmware engineer review this tomorrow, I will let you know what he finds.

:cheers:


#14

Thank you franz. Looking forward to hear what your findings are.


#15

So last night the sprinklers went off as planned and I got the correct notifications on my phone that the sprinklers ran. This morning the app / web-app showed the system “online.” However, like yesterday, the system did not respond to a manual sprinkler test. I checked the unit. Now it has two lower lights on and the third blinking. I have ruled this out to being a router issue. Something is screwy with my unit.


#16

@MikeyUSC,

Looking into the logs for your device, you are seeing it drop offline because the unit is trying to update its firmware. This update fails with the error code indicating that the unit was able to connect to the Wifi network, but it was not able to subsequently make a call out to the cloud to pull the new image. After that it takes your unit quite a while to come back online, and then the cycle repeats.

I’ll follow up with you on your support ticket about some next steps we can take to resolve the issue.

Cheers!

-Devin


#17

Thank you Devin! I called support this morning. They suggested I enable a guest network from my router. Apparently as the password for both 2.4 and 5 are similar, in theory the router keeps attempting to have the Rachio connect to the 5G. I created a guest network with a different password and connected the Rachio with that connection. So far so good. Going to test throughout the day if the connection is able to maintain online.


#18

@MikeyUSC,

Your device is online now and it pulled the firmware update, so it is definitely looking better now!

It would appear that workaround is holding up for now. I’ll still be looking into what is going on with that particular AP and our controller, so hopefully we can get you off that setup here in the future.

Cheers
-Devin


#19

Great! Thank you Devin!


#20

The first controller I set up in 2014 was connecting via a NetGear dual band router. I had a dickens of a time until I set up guest access just for the controller. It was taken offline for the winter and when it came time to start watering in the spring, the controller connected again with no problems. Don’t know if it was just NetGear, but some articles I read suggest that.

All other devices connect with no problems including my security system.

My other network uses a Linksys router and the controller blinked up with no problems. No need to set up a guest access.