Rachio 3 Not Responding in Homekit (Again)

I have tried both 2.4GHz and 5GHZz and still can’t get HomeKit to see it. I’m hoping new iOS14 will magically see the Rachio3.
At this point, I have no idea what else to do… Upgrade from 2 to 3 because of HomeKit and now totally not seeing the benefit.

Months ago, what worked for me was:
• Removing the controller from the Rachio app (*You will not loose data. It will come back when you login to your account( then,
• Reboot the phone (or iPad) and Rachio controller…
• Re-add the Rachio controller to your 2.4ghz network -ONLY-
• Login to the Rachio app and attempt Homekit setup

When I tap on the “Remove Controller” link I get a scary message saying “By checking this box you understand that removing this controller will permanently remove all data and settings related to this controller. This action cannot be undone.”

I ignored that warning and had to re-create EVERYTHING in the software. Since then I’m just waiting with a partial-functional unit until there is an official method of upgrading to the new firmware.

BEWARE that message, just as it says.

Are you having the same problem @philhagen where the controller cannot be added in apple home because it just doesn’t appear?

Yep - same as most of the rest of folks here. The Rachio 3 shows up in HomeKit, but shows “No Response”.
edit: When I previously removed it from HomeKit, it could not be re-added without a factory reset. That reset caused the loss of all zone settings.

You may want to call Rachio BUT I thought the controller data (schedule’s etc) was held in your account (at Rachio) -not- in the controller… **Unless something has changed. **Correct, I would not want to loose my data if that is the case…

*While troubleshooting in the past, I remember, in the past, that I have removed the controller from the Rachio app (*locally - then even “deleted” the Rachio app & re-downloaded the app. The data re-appeared once logged into my Rachio account (*locally on my iPhone)

Again, I am having no issues at all with Rachio / HomeKit on my Mac(s) X’s 3, iPhone, iPad and AppleWatch *in the Home Apps - see photos:


Yep I get it - and that’s what was supposed to happen… Yet there I was, re-adding everything from scratch. I have something like 150 different tiles running seamlessly in the Home app… The Rachio tiles showed somewhat of a successful addition for a few seconds, then went to “No Response” and stayed there.

Based on the this thread and my last experience “trying to start over”, I’m inclined to leave it broken for now and wait for an official upgrade path.

Are you removing the app only or remove the controller? I hate to lose everything again, this would be the 4th time I had reset and re-add

I don’t want to tell you the wrong thing. I know I have done it on a number of occasions in the past without losing data.

**I would not proceed without calling Rachio Support and confirming whether or not you lose data if you remove the controller from your app.

Is there a number to actually call Rachio support? I can’t find it anywhere and haven’t heard back yet on my support email. Thanks!

The phone I have for Rachio Support in my contacts is: ‭1 (844) 472-2446‬

  • I just tried and it works…
    Support was very good when I called them at initial setup in April '19
    ** You are correct, I am not able to find phone # on their website… Wow, I can’t imagine doing that to my customers.
1 Like

Talked to someone at support this morning (thanks @Macsterguy). She enrolled me in the upcoming beta test. She also made it sound like to do a factory reset but still keep my data I needed to uplug the rachio for 5 sec plug it back in and hold the stop button until the blue bar flashed.

Turns out that’s not totally accurate, you have to wait for it boot all the way back up (solid blue bar) then press the stop button until the orange fills up the bar, etc. etc. I didn’t end up doing the rest but I was able to finally see the rachio as a device to add in my apple home. Not sure if holding the stop button while booting up did something but it made the rachio available to add to homekit.

Immediately upon adding it my apple home it stopped responding again. ugh Looks like I’ll have to wait for the wifi chip firmware update.

Well at least that’s some thing… I’m really surprised it didn’t work. Just curious, what type of router do you have?

I use google nest wifi. I switched earlier this year to Eero pro’s but I kept having issues with the internet completely dropping out until you rebooted the primary Gateway Eero. So I ditched it and went back to the newer google nest wifi. It’s been OK. In addition I have a separate wifi for all my IoT devices using the last version of the apple airport extreme. I did this in the beginning for my Rachio 2 which didn’t support 5ghz and was losing connection. Then I started having problems with my leviton switches until I connected them to the 2.4ghz IoT wifi. The airport extreme is in bridge mode so it extends my network and let’s the main gateway google nest wifi assign those devices IPs, Subnet, DNS, etc.

Sounds complicated but I think it’s more simple that I’m making it sound. I looked at AmpliFi Alien Router which looked awesome… might try that next or the one you’ve been recommending. I’d really like someone else to come out with a homekit enabled router. Turns out I like to waste money of wifi setups :stuck_out_tongue:

Who has two thumbs and got his sprinklers working on homekit?

Upgraded to iOS 14 today.
All my HomeKit devices worked fine after the update except the rachio.

Had a hell of a time getting it working again. Ended up having to completely remove from HomeKit and after multiple tries finally got it to connect again to my wifi and then it took many tries to get it to add back into HomeKit.

Guess I’ll find out if it is anymore stable under iOS 14.

1 Like

This sounds like a serious bug only indirectly related to HomeKit. The Wi-Fi settings in the controller should be unaffected by any activities, except for pressing keys on the controller for Wi-Fi reset or complete factory reset, or by choosing Reconfigure Wi-Fi in the mobile app.

Do you know at what step in the process the Wi-Fi connection was lost?

I upgraded to iOS 14 and everything regarding my Raccio/HomeKit continues to work perfectly. I guess I will just consider myself lucky… I don’t understand why so many people continue to have issues. Hopefully everybody will be as happy as I am soon.

I second @Macsterguy. I haven’t had a single issue for about 6 months now, since getting the controller firmware downgraded to version 615. I upgraded to iOS 14 yesterday and it still looks solid