Rachio 3 Not Responding in Homekit (Again)

That’s what I thought.

They know there is a problem. They have worked out what the problem is. They are working on the problem.

Why is there any need for a lawsuit?

Exactly, at least they acknowledge the issue and appear to be working towards a resolution. If you want to talk lawsuit take a look at Ring - we have been waiting 4+ years for the promised HomeKit support.

It blows me away that mine works perfectly and in the few occasions where I’ve had to re-add it it was not a problem at all to do…

I have said this before In this thread, no need to respond… I find Rachio HomeKit integration nearly useless. You can turn it on and turn it off. You can do the same and much more in the Rachio app. I was watching some neighborhood kids on a security camera the other day playing in the front and gave them a good soaking. That’s about it

So why does mine work? It has got to be my router and how it handles IOT traffic. That’s all I can think of. It is as solid as a rock. It’s made by Synology check it out. I have both models they sell set up as a mesh network.

When Rachio gets this sorted out, if they ever do, you watch, mine will break and everybody else’s will work… I would consider that no loss at all and I started this thread…

Rachio is a excellent irrigation controller. I have told many people to buy one that ask about it. ***Unless they want HomeKit to work!

At the very least, Rachio should remove any mention of homekit from all packaging and ask Apple to take the Rachio 3 off of the HomeKit compatible devices on Apple’s website:

But a lawsuit? Really?

3 Likes

550 posts and no answers. Time for a class action.

Did the weekly updates stop? I’m surprised we don’t have a beta out there in the wild yet…

Unfortunately yes, they seem to be random now.

OK, Johnnie Cochran what kind of an answer are you looking for? If you read the 550 posts you will see Rachio has acknowledged the problem and is working on a fix. Just like everyone else I would like to see it out today but I assume its not ready.

Update!

Hey folks, here is an in depth update. Now that the ADK is compiling with our firmware the team hopes to make significant progress over the next two weeks. Thank you for your patience.

  • Compiling with Rachio firmware - COMPLETE
  • Homekit working in isolation, without all of the necessary services and characteristics (IN-PROGRESS)
    • First try to remove old homekit implementation
    • Bring-up new ADK based homekit without most features
    • Add back functionality for the necessary features and functions
  • Once features appear to work on the hardware regression test:
    • Homekit advertises all expected characteristics and services
    • Using homekit app allows zone control
    • Homekit provisioning

:cheers:

5 Likes

Thanks Franz.

That is great news, thank you!

Hey Franz, what’s with the 632 update that was pushed to everyone? You had manually pushed the 615 firmware back to my Rachio a while back and that fixed all of my HomeKit issues… I never received had a No Response error from HomeKit with 615.

Ever since the “upgrade” back to 632, it’s been completely broken, again.

I appreciate the updates, but would like to stay at 615 until you have a suitable replacement.

1 Like

I second this. I too was downgraded to 615 at my request back at the beginning of spring, and it worked great! But it looks like 632 was pushed from your side (I know I didn’t update it! I purposefully avoided that) and I’m experiencing the same issues as I was on 632 before.

1 Like

I thought it would be easisest to post current status here. Team is moving along, still making good progress.

6 Likes

I really love this.

This level of transparency I have never seen It in any company before.

You guys review the entire process and are rebuilding it as it should have been before. Its going to take a few month still to get to a point when you have de confidence to release to public.

My only question is: viewing the amount of work that needs to be done, what is your estimated period when all this will be finished, with the understanding that this can change and we have holidays in the coming weeks.

Agreed, I appreciate the transparency but this is all I am looking for.

This morning, I noticed that my Rachio3 controller had lost connection to my wifi network / home app for the first time in a very long time… I remembered our internet going down the other night for a brief time…

I went to the controller in the garage and hit the wifi button and noticed the process was different this time. A pop-up on my phone said (something like) “Since iOS 14.2, you need to go to iPhone settings / wifi / and join the Rachio3 to your Wifi network”…

This is the same behavior as many of my other home apps and what I would normally expect. Everything worked perfectly after re-joining and it didn’t take more than a couple of seconds to do so!

Now if we can just get the controller to re-join automatically like other devices…

It looks like things are moving in a good direction

1 Like

Before doing that, did you try a simple reboot (remove power, wait a few seconds, restore power)? Unless the internal Wi-Fi settings got corrupted or lost, I would expect the controller to reconnect without reconfiguring anything.

I don’t think you read what I typed very closely. I’m not having a problem. I simply stated that after a long long time my controller lost connection because of an Internet outage. I hit the Wi-Fi connect button and everything happened exactly as it should and unlike it has been happening. I haven’t had Raccio problems in over a year but was the original poster of this thread.

I did read it carefully.

IMO, it is not disputed that in recovering from temporary connectivity or power issues, Rachio performs worse than most other IoT devices. Rachio needs to fix that.

But there is a serious question here: Does the controller lose (or intentionally erase) its stored SSID and password, or is it just in a state where it can’t associate, authenticate or obtain an IP address from the access point?

If the latter, a simple reboot will get it back online. You don’t have use the mobile app and deal with different procedures that depend on firmware version and phone platform and OS version. A system that is unattended for long periods could be equipped with a Wi-Fi controlled socket as a workaround. You could even have a script to automate that.

But if it’s the former, that’s a much more serious deficiency. It would be a real challenge to recover without physical access to the device. In spite of dozens of threads whining about problems reconnecting to Wi-Fi, I haven’t seen a single credible post that answers the important question of whether the controller loses its settings or not. Since you are quite knowledgeable about Apple stuff, I was hoping that you could provide an answer.

I suppose i could have chosen to reboot the controller… If I had, I think it would have reconnected just fine. The point I was trying to make is that the process has changed when it comes to adding the controller to your Wi-Fi network.

To be honest I don’t use the app or homekit very much since this irrigation controller is so fantastic at watering my grass all by itself.