Rachio 3 Not Responding in Homekit (Again)

Thank you @Bgman! Will relay this to the team. Would you be up for power cycling your Rachio (not resetting.) You’ll just want to unplug the controller for about 10 seconds and then plug it back in - let me know if that changes anything.

P.S. I will be out of office starting today through October 14 - if I don’t respond, I promise I’m not ignoring you!

Thanks @laura.bauman. Before reading your post, I tried the reboot last night without success. However, I don’t think I waited a full 10 seconds before plugging it back in and will try again tonight. Enjoy your time off and I hope to hear back from you when you return.

1 Like

Keep us posted!! And thank you :slight_smile: I have a couple people internally keeping an eye on things as well so someone should be in here at some point! Talk in a few weeks :cheers:

@laura.bauman - I tried again making sure I left the unit unplugged for a full 10 seconds (i waited over an hour) before plugging it back in. Again, it still wasn’t showing up in the HomeKit app as being available to install.

1 Like

As another data point, iOS 13.1.2, iro3-firmware-hk-5-630, and a 10 second power cycle but still no Rachio Gen 3 accessory appearing in HomeKit.

1 Like

Hey team! Thanks for the testing and patience. Just getting back into the office after two weeks out - will check in on any progress from the Apple team.

:cheers:

1 Like

Unfortunately no updates from them. :sob: Will keep bugging them and will stay in touch.

@laura.bauman You are back, and didn’t say Hi? :slight_smile:

:cheers:

HI @franz !!!

1 Like

So this is getting very old. Seem easy for you to Blame Apple. But I expect Rachio to own fixing this. Bought my Gen 3 for Homekit support. I am sure others have as well. I am starting to wonder if there needs to be some type of class action lawsuit to either refund my money of get this fixed!!

Yeah I upgraded to the hen 3 for HomeKit support and it’s never worked for me :frowning: I’ve added it to my homebridge setup and it works fine… should have just stuck with my gen 1 and done the same

Hey friends! I’m truly sorry for all of the frustration around this integration. I got an update this morning that we’re getting closer to a fix, but we may not hear anything from our third parties until closer to the end of the year. I wish I had better updates; I’m waiting patiently with all of you.

:cheers:

Hopefully, with iOS 13.2 out, we will begin to see headway in this 8-month old problem?

Just got mine today. Got bit by this bug.

I set it up in my kitchen including downloading the firmware and setting up homekit.

Then installed it. Then set up each of three zones.

Then no response in homekit. Deleted it but was unable to add it back in.

It’s fixed now. This is how.
Held down the stop button for 10 seconds as suggested in this forum. Then added it back in. Then was able to add it back into homekit. So far so good but it’s been less than a day.

Two things that I think my have trigged this.
I have a mesh network and set it up next to a different base station then where it is installed. If noticed that sometimes this has been an issue. The other possibility is homekit showed all 8 zones when I first added it in. I then in your app turned off all but three and then set them up. Maybe homekit doesn’t like the groupings of devices changed behind its back. I think this was one of the new homekit features.

2 Likes

I haven’t tried this in a while… I had almost forgotten about it.

I just tried holding the stop button 10 seconds, then adding Rachio back to HomeKit. I can confirm that it worked!

Still holding as of today, over a week now

3 Likes

I know how frustrating this stuff is. I used to be a Mac tech back in the day.

I tried everything before finding this forum. Besides doing a reset I didn’t know that the phone had to be by the controller to reconnect. Seems it uses Bluetooth or something for that.

The app really could use a better error message other than it’s broken and we are working on it.

Happy to report that everything is working as of 11/4/19 in homekit

1 Like

Just adding a tally mark here. I’ve had my s3 since May and added it to HomeKit right away.

It hasn’t had an issue until this weekend. It’s not a huge deal to me as it’s winter but I did try to mess with it to get it working (without success.)

It’s just not showing up when I try to add it (I’ve completely memorized the number after entering it so many times…)

But I’ll patiently wait for a fix. As long as it’s available before Spring I’m good…

Worked for me as well.

Yep, mine worked for a few weeks but once again not responding in HomeKit. Very frustrating. I paid a lot more for this model due to HomeKit support and it keeps on going offline.

Guess I get to spend another 10 minutes or so resetting it once again.

Try holding down the stop button 10 seconds (or more), then adding Rachio back to HomeKit. I can confirm that it works!