Please HELP! New Rachio2 won't connect to server

Hello! We attempted to install a new Rachio Gen2 unit for our front yard on Aug. 3rd. It connects to WiFi (Lights 1 & 2 are solid) but is stuck on blinking light 3. We’ve reached out to support via the Rachio App with no response. We are in AZ and it is HOT here. Last thing we need is to lose all of our trees and plants. Can anyone please help? From the research I’ve been doing, it seems there may be an issue with our Firewall? Can I please get some guidance?

Hey @TB2! Would you be up for reaching out to our support team to troubleshoot? THey can get you online :slight_smile:


Scratch that - saw your existing ticket, pinging the team :slight_smile:

Oh thank you so much!!!

1 Like

You’re welcome :slight_smile:

@TB2 - in the event it isn’t sorted out yet.

  1. What flavor of the app is being used for setup iOS or Android? History has shown that the iOS version of the app handles the initial setup better.

  2. Run the RouteThis app so support can be provided the code to help understand the network.

  3. Can the WiFi environment be described? Mesh? Same SSIDs between 2.4 and 5 GHz networks? Router make?

@DLane - thanks for responding.

  1. iOS iPhone 6sPlus. We have a Rachio Smart Sprinkler Controller, 16 Zone 1st Generation that we run off of this app for our backyard. Works great since January 2017.

  2. Are there instructions for running the RouteThis app somewhere? Do I send to the support email for Rachio?

  3. Different SSIDs for the 2.4 and 5 GHz networks. I was able to connect to the WiFi and can see its connected for the 2.4 GHz network. I ran thru the troubleshooting gyrations about 10-12 times on Aug 3…
    Router is an Arris SBG6782-AC

Any guidance you can provide is appreciated! It’s 110-115 degrees here during the day. We’ve been watering manually with a hose.

If we take that at face value, it’s connected to your LAN but e.g. some firewall setting or DNS problem is preventing connection to the cloud server. As a first guess, try setting Protection Level in the router to Low.

If that’s not it, confirm that it’s on the LAN. If the gateway DHCP page lets you view connected devices, find its IP address there. Or, use a tool such as nmap to find it. From a computer or smartphone on your LAN, open that address in a web browser and you should see this message:
File / not_found
Report result.

If you can’t fix this quickly, temporarily set up a smartphone or other device as a hotspot (making mobile data available over Wi-Fi). Use another phone to configure the Rachio to use that Wi-Fi. Confirm that the controller functions and set up a fixed schedule, e.g. to run daily. You should now be able to turn off the hotspot and the schedule will run from the controller itself.

1 Like

Run this and provide the generated code and will have the engineering team review.


Go into your app and click more than you will see the controller settings menu at the very bottom you’ll see update Wi-Fi Network and it will guide you to the steps

Update the WiFi on the controller unplug your controller and then plug it back in
Immediately after plugging it back in hold down arrow and select until the LED ring is fully illuminated

Try visiting
when connected to your Wi-Fi. You should see a certificate error. If the browser just hangs or reports ‘connection timed out’ or similar, your firewall, parental controls or other restriction is blocking access to Rachio cloud server.

RouteThis code is U495ND89

Oops, I put the wrong port number in my previous post. It should be 8883. Do you see a certificate error trying to connect? Did you see the Rachio in your router’s Client List? Were you able to access the Rachio controller from your LAN?

We are able to see the Rachio controller in the router client list.
We were able to get connected via the hotspot connection and create schedules, then I did a quick run on one of the zones. I then tried to run the setup again to see if the controller would connect to the LAN…it will not. I haven’t looked for the certificate error yet. I do believe it is Firewall related, however, I do have the Firewall security set at Low.

Just to confirm that I have the facts straight, the first two lights are on solid, the third is blinking, the controller still appears in the client list, but you can’t access it with a local browser. Correct?

If so, does it respond to ping? Besides the one built into your router, do you have any other Wi-Fi access points or extenders on your network?

You need to disable the firewall or create a separate guest network for the controller. You are blocking necessary ports.

1 Like

I suspect that the Double NAT is caused by an access point, extender, mesh device, etc., that is configured as a router, in addition to your router/modem. Please describe all such devices on your network.

The word ‘guest’ does not appear in the SBG6782 AC User Guide, so that’s not an option. And their screenshot with Protection Setting at Low shows “No Services Are Restricted”, so I doubt that selecting Off would help. I’m reasonably sure that the Rachio is connecting to another AP of some sort, which is causing the trouble.

Edit: I was wrong; see post below.

Oops, my apology. There is a Guest Network Settings screen. I missed it because the reference appears only in an image.

If the Rachio is in range of the SBG, the Guest Network should do the trick. However, in the long term you should get rid of the double NAT.

Welp…I was trying to give access to those ports that are blocked because I had read somewhere in my research that access to those is necessary. Instead I blocked them due to my lack of understanding of the router language. This is why I reached out to all of you. Thank you! Now to figure out how to unblock them… I surely appreciate the guidance.

I’ll try a few things now and let you all know how it goes.