New Homebridge (HomeKit) plugin for older Rachio’s


#21

Thanks for responding. I got the api key from the account settings and looks like it doesn’t work. Should I contact Rachio to confirm with them about the api key as I read somewhere on a forum that it could be incorrect and Rachio can provide the correct one?

Regards,
B


#22

Verified the API Key is correct as I was able to just get the json to run with the
API Key
and Person ID

curl -X GET -H “Content-Type: application/json” -H “Authorization: Bearer API KEYhttps://api.rach.io/1/public/person/PersonID

and this pulls the data from my Rachio just fine.

I don’t understand why the config.json doesn’t work:

{
_ “platform”: “Rachio-Platform”,_
_ “name”: “Home”,_
_ “api_key”: “{API KEY}”,_
_ “internal_webhook_port”: 27546, _
_ “external_webhook_address”: “http://EXTERNAL PUBLIC IP:12453”_
}

I have the port forwarding enabled on my Cisco RV345P to forward traffic coming port 12453 to the internal port number 27546 to the internal IP address of the home bridge server.

I dont under stand why its getting stuck on getting client is not authorized.

Pleas suggest,


#23

Are the curly braces surrounding the key actually in your config? Remove those curly braces. Otherwise I don’t know. There’s a JSON test website available — but also keep sensitive information out of it.


#24

Thanks a ton. It was curly brackets. I’m still getting used to coding…


#25

Can the timer for running the sprinklers be in sequential instead of having it in increments of 5?

The plugin is awesome other wise. Good work.


#26

@Kubisuro With the coding assist!

:cheers:


#27

This is exciting! I’m already an avid homebridge user (nest, TP-Link, IFTTT). I just ordered a gen 2 system last night and can’t wait to get it working with HomeKit this weekend. Great work @Kcharwood !


#28

…and done! Happy to report the installation and setup are now complete, and the Homebridge configuration worked flawlessly. Thanks again!


#29

I finally got around to setting this up with beta4. I keep getting a “rate limit exceeded” message. Testing port forwarding shows the rachio plugin responding to port activity. Suggestions?

So, today I am seeing “client not authorized”. I’m sure my key is correct.

Last response from the plugin author at the plugin repository was in March. Has this plugin been abandoned?

edit Found my typo! It seems to be working now.