Monthly data usage of the Rachio Iro

I am the president of an HOA and I would like to use a Rachio Iro to control our sprinklers (8-10 zones). The controller will be in a locked box attached to the outside of a brick pillar that is part of a fence. My plan is to put a T-mobile hotspot device in the box with the Rachio. T-mobile will give us 200 Mb/month of data for free. Will this be enough data to operate the Rachio?

@dblagent007 That should be plenty of data, our messages are < 4k each and I would expect less than a couple dozen per day. I’ll let @emil speak to using a hotspot. I think we’ve had mixed success but can’t remember exact details. We are modifying the device firmware this week to be more resilient to WiFi connection drops so any data will be buffered and sent to our cloud when the device reconnects to WiFi (assuming no power outage).


@dblagent007, thanks for reaching out and thank you for your interest in our product!

Are there any WiFi networks from nearby houses you could connect to?

I’ve seen mixed results with hotspots. I know a few users have had good luck with FreedomPop – might be worth checking out:

If anyone has had good luck with a mobile hotspot, please let us know.

Thanks, Emil

I might be able to connect to the wifi at a nearby home, but that setup isn’t ideal. It would be better if the HOA has a stand alone system that isn’t reliant on anyone else.

Can you elaborate about why mobile hotspots have been problematic? I’m leaning towards trying the T-mobile setup because it will only cost $15 for the hotspot (T-Mobile Sonic 4G Huawei UMG587 GSM Mobile Hotspot) and the data is free.

If that doesn’t work, then I could give Freedompop a try (thanks for the tip). I know we get 5 bars of coverage with any mobile provider because there is a huge tower less than 1/4 mile away.

@dblagent007, good question. This is usually due to the the hotspot’s connectivity settings. To conserve battery life, they usually stop broadcasting the Wi-Fi signal after a pre-set default time. Sometimes, plugging in the hotspot fixes the problem. It varies from one to another. I haven’t heard of any issues with the FreedomPop unit, so I assume there’s a default setting that keeps the hotspot from going into a “sleep” mode. In any event, I’d recommend testing the hotspot before pairing it with the Iro.

Hope this helps.

Best, Emil

That makes sense. I checked the settings for the hotspot device I want to use (Huawei UMG587) and it allows me to set the WiFi to always on. I think this is going to work. I’ll try to remember to update this post in a couple of months.