iOS notifications


#1

I just installed my Rachio a little over a week ago. Everything appears to be working fine with the exception of iOS notifications. I have not yet received a single push notification (despite several ongoing changes to my device history shown in the web app). I have reinstalled the app multiple times on both my iPhone 6 and iPad Air. I have even set the date/time ahead in order to get the notification dialogue box. I have contacted support twice, but they claim that push notifications often get lost in the cloud. I can understand how 1-2 could get possibly delayed or even lost, but I expect to be able to get some/most notifications. FYI, I have a WiFi-connected Ring doorbell and those iOS notifications are extremely reliable via their cloud provider. Does anyone have any suggestions? I think I have tried about everything with the exception of a factory reset to the Rachio.


#2

Hi @PurdueFan9,

Good evening. Thanks for reaching out. I believe the support team provided this support article on push notifications. There are certain instances where an app that has push capabilities stops leveraging Apple’s Push Notification Services (APNS). This can happen for a few different reasons. But there’s no error correcting for this process, as such you’ll want to reset the app back to what amounts to a factory default status in order to get Push working again.

The first time an app is opened, it will register for push notifications and prompt for receiving push notifications for the app. This prompt never occurs again unless the app is uninstalled for a minimum of a day and then reinstalled. You can duplicate this functionality by simply deleting the app and then installing the app again after setting the Date & Time manually a day ahead of the current date. You would do this by following the steps below:

  1. Tap on the app and hold it until the the apps display an X.
  2. Tap the X to delete the app from your device.
  3. Turn the iOS device off completely.
  4. Turn the iOS device back on.
  5. Open the Settings app.
  6. Tap on General.
  7. Tap on Date & Time.
  8. Move the date ahead a day or more.
  9. Close the Date & Time Preferences.
  10. Turn the device off completely again and turn it back on.
  11. Open the App Store and download your app again.
  12. Open the App.
  13. Respond to the Push notification dialog.
  14. Set your Date & Time back.
  15. Enjoy!

Here’s a 3rd party article that details the steps listed above.

Please let us know if this doesn’t fix the issue.

Best, Emil


#3

Thanks, Emil. I have completed that procedure multiple times on both my iPhone and iPad. It does indeed give me the push notification dialogue box during the app re-install, but still no notifications. Note that I have received a couple of email notifications and also my device history shows several rain sensor activations and deactivations. Do I need to be on the same WiFi network as the Rachio in order to receive push notifications?


#4

No, any internet, cellular connection.

Very odd, so starting/stopping a zone manually does not give any push notifications?

Just to double check I would look in the app preferences to make sure push is allowed.

Also, make sure in our app under user preferences allowing push is enabled for events. Hopefully we can get to the bottom of this. We haven’t heard of anyone else with push issues other than settings disabled, etc.

:cheers:


#5

Thanks, Franz. That is correct. I have a drip line that I have been manually turning on/off, but no push notifications. As I am an engineer, I decided to load The Rachio app on some additional devices to try to gather more data. I loaded it on a iPhone 5C as well as an iPad 2. This morning I was able to generate a couple of push notifications on the iPad 2, but not on any of the other 3 devices. Interestingly, the iPad 2 is still running iOS8.3 so it downloaded he older version 1.8.6 of the Rachio app. Therefore, I no longer believe this is a cloud issue. I now think this most likely a bug with the latest version (2.0.1) of the Rachio app. I am likely one of the few people to install a new system in the past week so I don’t believe that I ever had version 1.8.6 installed. Also, note that ever time I re-install the Rachio app, it always installs as an update and is added to the Updates tab of the App Store app which is very unusual. I expect that if you could send me a link to allow me to install version 1.8.6, then update it on my device to 2.0.1 it would likely work. I will also try to do some additional testing on my iPad2 to test this theory.


#6

@PurdueFan9 hmmm, very interesting. I’ll work with @matt and try to figure out what is happening.

Thanks for this.

:cheers:


#7

Hi @franz,

Sorry but I am also having issues with notifications and emails. All options under app and user preferences for Rachio are on but I am getting nothing. Under settings, the reported build is 1.8.0 although I am using 2.0.1 if this matters.

Regards,
Dariusz


#8

@franz & @matt, I did some additional testing on the iPad2 this morning. As previously indicated, push notifications worked running ver 1.8.6 on iOS 8.3. I then updated to iOS 8.4 and notifications still worked running ver 1.8.6. I then updated the app to ver 2.0.1 and notifications continued to work! Therefore, I think the issue likely only affects people who never had ver 1.8.6. As of now, I still cannot receive any push notifications on the other 3 devices. Hopefully, you can either send the link to install the old ver (1.8.6) of the app and/or release an app update once you determine the root cause.


#9

@PurdueFan9 great thanks for this, we’ll figure the issue out.


#10

We found root cause, fix will go out in next iOS release. Thanks!

:cheers:


#11

Great news! Thx, Franz & Rachio team!!


#12

@PurdueFan9

iOS 2.0.3 just went live on Apple app store, should fix this issue.

:cheers:


#13

Outstanding! Thanks, Franz & Rachio team!!


#14

Is there something special I need to do besides updating the app? I am still not getting notifications as of this morning. I have tried opening the app (I had not opened it after updating) and then manually kicking off a zone but still nothing. Do I need to re-install from scratch?


#15

@bslater I would first make sure the app notifications are enabled in iOS (iOS --> Settings --> Notifications --> Rachio), if they are this is a brute force approach.

:cheers:


#16

@franz, I’m very pleased to confirm that I received my first iOS push notification on my iPhone as well as on my Apple watch last night after upgrading to version 2.0.3! @bslater, I would recommend that you start a manual zone for a few minutes and then see if you get the push notification upon completion as I did. Now, we just need an Apple watch companion app!


#17

@bslater, are you still having issues with your notifications?


#18

Sorry, I forgot to come back and post! Mine weren’t corrected by the update, but I think mine was an odd case. I had recently gotten my iPhone replaced under warranty, and I think for whatever reason, my new one wasn’t getting those notifications. I tried a bunch of things to no avail, and finally used my iPad to initiate the Iro a couple of times. After doing that, the iPhone started getting notifications again. It was an odd one, but I am back to normal now! Thanks


#19

This is still an issue. I also replaced my device this week using restore onto new device. I also uninstalled the app on the new device and reinstalled. Got the push notification prompt and still no Notifications.

Pretty easy test case. Apple must have a support article on how to handle this properly.