Generation 2 - CAN connect to Wifi - CANT connect to Rachio AWS cloud


#21

Interesting. I wonder if it’s not taking the default gateway from DHCP.
In your packet logs do you see an mDNS packet right after DHCP completes?


#22

I just SSH’d in to the USG gateway, and also pinged it from there as well, so it would show up in the Wireshark trace. In the trace, I can show you that the owner of .250 is the Rachio based on the MAC address. If I change the filter from eth.addr == x to ip.addr == 192.168.10.50, after the DHCP traffic, I only see IGMPv2 traffic. (and the ICMP traffic from the USG, since I pinged it from there.)


#23

When switching to my ip.addr filter looking only for the .250 address I only see the following 3 frames, over and over.

DHCP Offer
DHCP Ack
IGMPv2

Repeat


#24

Since it was listening on a mirrored port, it was easier to just get a picture and sent from this laptop - apologies for the bad photography.


#25

Here’s a few more pics. Let me know if you want any other info.

RachioControllerAliasInUSG

Thanks,
Eric


#26

For anyone interested in the final resolution, there were in fact two.

The first one which was more of a work around, that took a lot of my time and money was resolved in part with the purchasing of the 3rd router for testing, based on what I read worked for others in the community forums. This particular Gen2 - I don’t know if it was just the couple of controllers that I tested or a larger handful from a specific batch, but I did test two different Gen2’s and neither worked with my R7000 or my USG Pro 4, during the initial add operation. It did work with the Asus RT-AC68U router however. I actually plugged this router in behind my USG Pro, setting up a double NAT scenario, and when the Rachio was using the Asus router, it added just fine, so I continued my testing and just added another WLAN/SSID that had the same name and password as the ASUS to my existing environment, turned the Asus router off, and then plugged the Rachio back in so that it would connect to my Unifi APs, and it worked just fine. Quite the work around, but that got it working. The only issue is that if I needed to reset the Wifi or set it back to factory defaults, I’d need to still have the Asus in place, which I didn’t want to use. After a lot of Wireshark traces, i was just able to show that the Rachio showed different behaviors (as far as connecting to the network) when doing an initial add operation vs adding it, and then rebooting it after it’s been successfully added.

When doing the initial add operation when plugged in behind the R7000 or the USG Pro, the Rachio would pull an IP address that I had reserved then send out some IGMPv2 traffic, and that was it. It never did a DNS request as it was supposed to. After being added successfully using the ASUS, then unplugging both the ASUS and the Rachio, and then plugging the Rachio back in, after adding the same SSID / Password to my existing network, and watching on the mirrored port (again, with Wireshark) I could see the behavior that it should have been doing initially immediately - if anyone is interested in seeing the Wireshark traces, let me know as I’ve saved them. I’ve sent this info and a lot more detail to the Rachio team, so hopefully they address that for the Gen2.

As far as the second and final resolution, they sent me a Gen3. That immediately worked the first time with no workarounds and no troubleshooting. It was quite refreshing. After dealing with these issues for about a month now, I’m glad that it’s finally over. After all of this, hopefully this thread helps someone else.

Cheers,
Eric


#27

I had issues with getting my Rachio 2 to connect to the wifi. i tried several things but not to the extend you did. i bought it and returned it on the same day, today… maybe i will try the gen 3 and see if i can get it going on the wifi before i try to install it like i did with the Rachio 2. that was a waste of time, currently debating whether i should put my old controller back or try the Rachio 3.


#28

@mpicon Sorry to hear that. The Gen 3 has an entirely different WiFi module that supports 2.4g and 5.4g. It might work better with your router. Also, make sure the firmware on your router is up-to-date.

:cheers: