Gen2 Rachio won't join the network. Defective?


#1

Just got the Rachio from Amazon, set up fought me every step of the way. Now it’s stuck at joining my network. It just times out. No rhyme nor reason, just an “Ok” button which is not acceptable to click!!

So return to Amazon and try another brand? Why can’t this crap just work?!


#2

@plissken99 Sorry to hear you’ve had a rough installation process! We are always looking for feedback so if you don’t mind letting me know the issues you ran into during the process I would appreciate it- but for now let’s get you online! Just emailed you through support so we can troubleshoot. We don’t want you to return to Amazon- we haven’t even gotten to show you the good stuff yet :cry:


#3

I know I had to try a couple times to get mine to connect. What error are you getting? What have you tried? Im sure people here can help you.


#4

Same here. Going to take down the controller tonight. I must have water for overseeding. The transformer is so hot. Has worked great until today.