Flex Daily Ran When It Shouldn't Have

I’m sure you see that headline a lot so let me tell you specifically what happened in my case. Been on a Flex Daily schedule for about 6 weeks now in the Pacific Northwest and things have been working great. We’ve been getting nothing but rain so far this “summer” and Flex Daily has decided, appropriately, not to water more than once, I believe.

Two days ago we received a whopper of a rainstorm. My rain gauge measured 2" of rain over night! My back yard is level grass in mostly shade and it was muddy and wet. Checking the schedules and nothing was planned, as I would expect.

Imagine my surprise when I woke up this morning to find that, of the four zones that I have, the controller decided to run my back yard grass zone for 26 minutes last night! My rain gauge now measures 2.5"!

And to make matters worse, it’s pouring rain out right now! And the skies have been cloudy for most of the last few weeks (as is typical here).

So what gives? I’m trying to figure out why Flex Daily would decided to run in between two rains – and of all zones to choose, it ran the one zone that was most saturated. I have it set up with the default “weather intelligence network” and to skip when rain exceeds 0.125. (This most recent storm was pretty widespread and persistent.)

Was there an error in the Flex Daily schedule (as I see happened once before)? Do I have a setting wrong? Anything else I should check? Attaching some screenshots for you. Ideas appreciated.

Your best bet is to find a local PWS that seems to have good data. I tried weather intelligence plus when I first got my Rachio 3 and I wasn’t happy with it I quickly switch back to a PWS within 1 mile away and it has been much better for me.

Thanks for the response @Anthony. I’ve tried that in the past but couldn’t seem to get it to work. I choose a weather station near me, then I click the back arrow and I get a “No Information Found” error. Perhaps I’m doing it wrong? I get that error for all weather stations I choose.

That seems odd if you click through the “more” tab on your Rachio app, select “ controller settings “, then Choose “weather intelligence plus

Select the weather station listed under the weather station menu will open and display available weather stations in your area will (listed base on distance from your home).

Ok, first time I tried online but I just tried in the app and I get a “something went wrong” error – pops up regardless which weather station I pick. Says if it continues I should contact support so I guess I’ll do that.

But I thought the ‘weather intelligence network’ was supposed to be much better than an individual station, no?

@dano Can you try now? It looks like you purchased Thrive, were then given the WI+ feature and it didn’t get fully transferred over.



Hi @franz, yes that worked. I was able to select a weather station .16 miles from my house.

Do you think that will help with my problem on the Flex Daily schedule? I was really surprised it ran at all.


Yes, it should not have ran if it received the correct information.

Are sure the chosen station is accurate? Not seeing any precipitation data for the month.

Whoa! Really?? LOL. We have had soooo much rain here. Thanks for catching that, Franz. I see now that you can view the actual data. I chose the station just next to it that seems to have precipitation data and it looks more accurate (attached). I’ll try that and see how it goes.