Brand new gen3, first installation, doesn't connect to wifi

Please, I have a brand new gen 3 controller and I’m trying to set it up through a just installed Rachio app (xiaomi mi mix 3 5g, Android 9).
At the Connect Rachio to Wi-Fi screen, there’s no wi-fi network.
I also ran Route this, and got code 8F859GTD.
Could you please provide some help?
Thank you

Are there any troubleshooting lights on the Rachio controller itself?

Also, is your normal power 110 or 220v?

Thank you.
White ccm123
Blue 4
Blinking yellow 5678910

My controller is powered with 24V AC, 1000mA.

My wi-fi network is 2.4 GHz, open, passwordless.


Your controller seems to indicate that it is up and running, and waiting to be setup with a wifi credentials.
Have you tried to restart the process, similar to what is described here (youtube link)?

Thank you Gene for your kind answer.
The problem is that there is no wi-fi network listed on the Connect Rachio to Wi-Fi screen.
So I cannot select my wi-fi network and there I am stuck.

As for the YouTube video, it states that wifi reset should be performed only if the controller has been activated. And I guess my controller is stuck in between…

Any other suggestion?
Thank you!

I think it’s simply the question of which button to press. Whereas with an activated controller, you’d go to settings to find the option to set the wifi, for a new controller, you’d simply follow the setup process for adding the controller for the first time. Reset prior to retrying to add the controller would not hurt.

I do remember that some users with Android phone, has success of using an older iphone they had lying around. Is there an iOS device you could burrow for the setup?

I have not heard of this symptom before, but you are the first to post about connection to an open network.

IMO there are three possibilities:

  1. Rachio 3 does not support connecting to an open network.
  2. Your Wi-Fi signal at the controller is weak and Rachio doesn’t see it.
  3. The app is malfunctioning on your phone.

First, with your phone placed next to the controller, confirm that your Wi-Fi signal is reasonably strong. If you have only one or two bars, run a speed test or report signal strength from a Wi-Fi analyzer app.

If your router or access point(s) support multiple SSIDs, set up another network with a password, confirm that your phone can connect to it, then rerun the Rachio app and see whether the new network shows up.

If you have access to another mobile phone, temporarily set it up as a hotspot (with a password), confirm that your phone can connect to it, then see if you can use the app on your phone to provision Rachio to the hotspot network. If that succeeds, set up the hotspot as an open network, confirm your phone can connect to it, then try to provision the Rachio controller on the open network.

With the results of these tests, we should be able to find a solution.

1 Like

Spent hours yesterday trying to install the Gen3 controller because it would not connect to my network from my iPhone. VERY FRUSTRATING. It must be IOS related. I ran the RouteThis app diagnostic test and that proved worthless when I contacted support. The way I resolved this was to use my iMac (about 5+ years old) to connect to the Rachio Gen3 access point. It prompted me to select what network to connect too and it worked fine.

Rachio may want to look at changing how the device is connected. I have not had this type of issue with my Nest device, Lutron switches or my Kasa outlets.