Adjusting watering time without affecting saturation skips?

I setup my trees on a fixed schedule with a drip system. The default watering time was set at 1hr 8mins when I set it to every 3 days. I found that was not enough watering and after some experimentation I settled on 2 hours watering time.

The problem is when I water for 2 hours, when I reach the 3rd day the rachio is trying to do a saturation skip. For now, I have disabled it, but I would like to account for rain and weather. How do I make 2 hours the “right” amount of water on a 3 day schedule to not trigger the saturation skips?