25F, schedule didn't skip


#1

Hey folks! That time of year in North America where we have to start watching the temperatures. Tahoe got a dusting of snow yesterday, and temps dropped into the 20s last night. Time to wax the skis! Unfortunately, I woke up to notifications that Rachio did it’s usual thing and watered several zones last night… :scream:

The weather data in the app is currently showing 23F - any idea why this ran last night? It’s configured to use NOAA’s KTRK weather station, which was reading around 25F at time that the schedule ran this morning. I realize I can set up skips via IFTTT, but I was under the impression that the logic to freeze-skip was built into the Rachio code now…


#2

@jlkinsel

I did some research and this does look like an issue with some flex schedules. It looks like some newer flex schedules are getting created with freeze delay disabled.

We will patch the code to enable this feature by default, and your flex schedule has been updated correctly.

Thanks for reporting this!

:cheers:


#3

Great! Thanks for the tweak!

Out of curiosity - is freeze delay configurable in the UI, maybe API, or just a back-end thing?


#4

@jlkinsel

Great question, it is not currently configurable through the UI.

We’ve corrected the current flex schedules to have this enabled by default.

In our next major release of the software for next year I want to have all of this configurable.

Have fun skiing soon!

:cheers: :colorado:


#5

My flex schedule went off today at 36F. I thought this was fixed?


#6

I am on daily flex schedule. How do I select weather intelligence to ensure freeze skip?


#7

Flex daily is fixed at 32F for freeze skipping.

Flex daily will skip if the current temperature is freezing (32F).

In a future release we will make this temperature fully adjustable.

For now, you can either set a rain delay on the dashboard of the app, put the controller in standby mode, or just disable the flex schedule.

Hope this helps.

:cheers:


#8

I think I have a related issue. Why would one schedule be skipped for the wrong reason? Or maybe the reporting reason is incorrect? Today temps were at 32 deg, and the following was done in my schedules as reported by Rachio: (There is no rain forecasted for the next week)


#9

@edbianc

The message is a little confusing.

When free delay is detected, it actually sets a rain delay on the controller.

When the last schedule was going to run, the system detected there was already a rain delay (actually a freeze delay) in place and skipped it but reported the technically wrong reason. I’m assuming if the previous delay wasn’t in place, it would have been skipped due to a freeze delay.

This process is being cleaned up for next year where each schedule will be autonomous and not affected by these global delays. We will also be able to notify you much much sooner (24 hours?) as to the decisions the system will we taking.

:cheers:


#10

Ok thanks.


#11

Two question to Frank or anyone in the community;

  1. Did this update roll?
  2. What temp should trigger the freeze guard.

Here was my event this week where my Rachio skipped water flex schedule on Mon and again on Tue due to empty in the high 20’s. The issue was on Wed where it resumed or watered at midnight even though my configured weather station .2 miles from my address shows it recorded temps at 27 degrees before midnight and 26.6 degrees at 12:06am. Is this feature working for others? I sustained property damage and wonder if I trust this feature. For now in I have it in standby mode till temps rise…


#12

I’m not 100% sure if freeze skip applies to this, but for some other weather-related events, Rachio checks what the forecast will be one hour before the schedule runs. So I’m wondering if the 11PM forecast showed temps 32+ F, but when midnight rolled around, actual temps were lower?


#13

Good thought however after checking temp was 27.7 degrees. Weird limitation after poking around is the inability to view current firmware version so not sure how to square if there is a bug. Still a mystery…